CVEvulnerability
CVE-2024-39320
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-07-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-1021, CWE-74
Description
Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.
Affected configurations
• discourse discourse (< 3.2.5)
• discourse discourse 3.3.0
Related
References
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210 Patch
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-4p82-xh38-gq4p Vendor Advisory
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210 Patch
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-4p82-xh38-gq4p Vendor Advisory