CVEvulnerability
CVE-2024-39573
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-07-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-20
Description
Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy.
Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Affected configurations
• apache http server (>= 2.4.0 < 2.4.60)
• netapp ontap 9
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://httpd.apache.org/security/vulnerabilities_24.html Vendor Advisory
- https://security.netapp.com/advisory/ntap-20240712-0001/ Third Party Advisory
- http://seclists.org/fulldisclosure/2024/Oct/11 seclists.org
- http://www.openwall.com/lists/oss-security/2024/07/01/11 Mailing List
- https://httpd.apache.org/security/vulnerabilities_24.html Vendor Advisory
- https://security.netapp.com/advisory/ntap-20240712-0001/ Third Party Advisory