CVEvulnerability
CVE-2024-39863
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-07-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-79
Description
Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.
Affected configurations
• apache airflow (< 2.9.3)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/apache/airflow/pull/40475 Issue Tracking, Patch
- https://lists.apache.org/thread/gxkvs279f1mbvckv5q65worr6how20o3 Mailing List
- http://www.openwall.com/lists/oss-security/2024/07/16/6 www.openwall.com
- https://github.com/apache/airflow/pull/40475 Issue Tracking, Patch
- https://lists.apache.org/thread/gxkvs279f1mbvckv5q65worr6how20o3 Mailing List