CVEvulnerability
CVE-2024-39877
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-07-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-277, CWE-94
Description
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
Affected configurations
• apache airflow (>= 2.4.0 < 2.9.3)
Related
References
- https://github.com/apache/airflow/pull/40522 Issue Tracking, Patch
- https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1 Mailing List
- http://www.openwall.com/lists/oss-security/2024/07/16/7 www.openwall.com
- https://github.com/apache/airflow/pull/40522 Issue Tracking, Patch
- https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1 Mailing List