CVEvulnerability
CVE-2024-40635
7.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-03-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.6 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-190
Description
containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
Affected configurations
• linuxfoundation containerd (< 1.6.38)
• linuxfoundation containerd (>= 1.7.0 < 1.7.27)
• linuxfoundation containerd (>= 2.0.0 < 2.0.4)
• debian debian linux 11.0
Related
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness
References
- https://github.com/containerd/containerd/commit/05044ec0a9a75232cad458027ca83437aae3f4da Patch
- https://github.com/containerd/containerd/commit/1a43cb6a1035441f9aca8f5666a9b3ef9e70ab20 Patch
- https://github.com/containerd/containerd/commit/cf158e884cfe4812a6c371b59e4ea9bc4c46e51a Patch
- https://github.com/containerd/containerd/security/advisories/GHSA-265r-hfxg-fhmg Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2025/05/msg00005.html Mailing List, Third Party Advisory