CVEvulnerability
CVE-2024-41131
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-07-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-787
Description
ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. All users are advised to upgrade to v3.1.5 or v2.1.9.
Affected configurations
• sixlabors imagesharp (>= 2.1.0 < 2.1.9)
• sixlabors imagesharp (>= 3.1.0 < 3.1.5)
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://github.com/SixLabors/ImageSharp/commit/9dda64a8186af67baf06b6d9c1ab599c3608b693 Patch
- https://github.com/SixLabors/ImageSharp/commit/a1f287977139109a987065643b8172c748abdadb Patch
- https://github.com/SixLabors/ImageSharp/pull/2754 Issue Tracking
- https://github.com/SixLabors/ImageSharp/pull/2756 Issue Tracking
- https://github.com/SixLabors/ImageSharp/security/advisories/GHSA-63p8-c4ww-9cg7 Vendor Advisory
- https://github.com/SixLabors/ImageSharp/commit/9dda64a8186af67baf06b6d9c1ab599c3608b693 Patch
- https://github.com/SixLabors/ImageSharp/commit/a1f287977139109a987065643b8172c748abdadb Patch
- https://github.com/SixLabors/ImageSharp/pull/2754 Issue Tracking
- https://github.com/SixLabors/ImageSharp/pull/2756 Issue Tracking
- https://github.com/SixLabors/ImageSharp/security/advisories/GHSA-63p8-c4ww-9cg7 Vendor Advisory