CVEvulnerability
CVE-2024-4181
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-05-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 8.8 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
Affected configurations
• llamaindex llamaindex (>= 0.9.47 < 0.10.13)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/run-llama/llama_index/commit/d73715eaf0642705583e7897c78b9c8dd2d3a7ba Patch
- https://huntr.com/bounties/1a204520-598a-434e-b13d-0d34f2a5ddc1 Exploit, Third Party Advisory
- https://github.com/run-llama/llama_index/commit/d73715eaf0642705583e7897c78b9c8dd2d3a7ba Patch
- https://huntr.com/bounties/1a204520-598a-434e-b13d-0d34f2a5ddc1 Exploit, Third Party Advisory