CVEvulnerability
CVE-2024-41937
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-08-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link.
Users should upgrade to 2.10.0 or later, which fixes this vulnerability.
Affected configurations
• apache airflow (< 2.10.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/apache/airflow/pull/40933 Patch
- https://lists.apache.org/thread/lwlmgg6hqfmkpvw5py4w53hxyl37jl6d Third Party Advisory
- http://www.openwall.com/lists/oss-security/2024/08/21/3 www.openwall.com