CVEvulnerability

CVE-2024-41964

8.1 HIGH Published 2024-08-29 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-08-29
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
CVSS 3.1 ([email protected])
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-863

Description

Kirby is a CMS targeting designers and editors. Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages.* wildcard permission for a role could not have prohibited updates to existing language definitions. The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The problem has been patched in Kirby 3.6.6.6, Kirby 3.7.5.5, Kirby 3.8.4.4, Kirby 3.9.8.2, Kirby 3.10.1.1, and Kirby 4.3.1. Please update to one of these or a later version to fix the vulnerability. There are no known workarounds for this vulnerability.

Affected configurations

• getkirby kirby (< 3.6.6.6) • getkirby kirby (>= 3.7.0 < 3.7.5.5) • getkirby kirby (>= 3.8.0 < 3.8.4.4) • getkirby kirby (>= 3.9.0 < 3.9.8.2) • getkirby kirby (>= 3.10.0 < 3.10.1.1) • getkirby kirby (>= 4.0.0 < 4.3.1)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References