CVEvulnerability
CVE-2024-42516
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
Description
HTTP response splitting in the core of Apache HTTP Server allows an attacker who can manipulate the Content-Type response headers of applications hosted or proxied by the server can split the HTTP response.
This vulnerability was described as CVE-2023-38709 but the patch included in Apache HTTP Server 2.4.59 did not address the issue.
Users are recommended to upgrade to version 2.4.64, which fixes this issue.
Affected configurations
• apache http server (>= 2.4.0 < 2.4.64)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://httpd.apache.org/security/vulnerabilities_24.html Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/10/2 www.openwall.com
- http://www.openwall.com/lists/oss-security/2025/07/10/3 www.openwall.com
- https://lists.debian.org/debian-lts-announce/2025/08/msg00009.html lists.debian.org