CVEvulnerability
CVE-2024-43115
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-09-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script.
This issue affects Apache DolphinScheduler: before 3.2.2.
Users are recommended to upgrade to version 3.3.1, which fixes the issue.
Affected configurations
• apache dolphinscheduler (< 3.2.2)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://lists.apache.org/thread/qm36nrsv1vrr2j4o5q2wo75h3686hrnj Mailing List
- http://www.openwall.com/lists/oss-security/2025/09/03/1 www.openwall.com