CVEvulnerability
CVE-2024-43204
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-918
Description
SSRF in Apache HTTP Server with mod_proxy loaded allows an attacker to send outbound proxy requests to a URL controlled by the attacker. Requires an unlikely configuration where mod_headers is configured to modify the Content-Type request or response header with a value provided in the HTTP request.
Users are recommended to upgrade to version 2.4.64 which fixes this issue.
Affected configurations
• apache http server (>= 2.4.0 < 2.4.64)
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://httpd.apache.org/security/vulnerabilities_24.html Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/10/2 www.openwall.com
- http://www.openwall.com/lists/oss-security/2025/07/10/4 www.openwall.com
- https://lists.debian.org/debian-lts-announce/2025/08/msg00009.html lists.debian.org