CVEvulnerability
CVE-2024-44088
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2025-10-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover.
This issue affects Apache Geode: all versions prior to 1.15.2
Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Affected configurations
• apache geode (>= 1.1.0 < 1.15.2)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://lists.apache.org/thread/161r34nokmcc0w74mnf04lskgb8g1d3g Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/10/14/5 www.openwall.com