CVEvulnerability
CVE-2024-45411
8.6 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-09-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- Weaknesses
- CWE-693
Description
Twig is a template language for PHP. Under some circumstances, the sandbox security checks are not run which allows user-contributed templates to bypass the sandbox restrictions. This vulnerability is fixed in 1.44.8, 2.16.1, and 3.14.0.
Affected configurations
• symfony twig (>= 1.0.0 < 1.44.8)
• symfony twig (>= 2.0.0 < 2.16.1)
• symfony twig (>= 3.0.0 < 3.14.0)
Related
Weakness · CWE (1)
- CWE-693 Protection Mechanism Failure weakness
References
- https://github.com/twigphp/Twig/commit/11f68e2aeb526bfaf638e30d4420d8a710f3f7c6 Patch
- https://github.com/twigphp/Twig/commit/2102dd135986db79192d26fb5f5817a566e0a7de Patch
- https://github.com/twigphp/Twig/commit/7afa198603de49d147e90d18062e7b9addcf5233 Patch
- https://github.com/twigphp/Twig/security/advisories/GHSA-6j75-5wfj-gh66 Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2024/09/msg00031.html lists.debian.org