CVEvulnerability
CVE-2024-45605
4.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-09-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-639
Description
Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.
Affected configurations
• sentry sentry (>= 23.9.0 < 24.9.0)
Related
Weakness · CWE (1)
- CWE-639 Authorization Bypass Through User-Controlled Key weakness
References
- https://github.com/getsentry/self-hosted Product
- https://github.com/getsentry/sentry/pull/77093 Issue Tracking, Patch
- https://github.com/getsentry/sentry/security/advisories/GHSA-54m3-95j9-v89j Vendor Advisory