CVEvulnerability
CVE-2024-45719
2.6 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2024-11-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 2.6 LOW — CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
- Weaknesses
- CWE-326
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.0.
The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable.
Users are recommended to upgrade to version 1.4.1, which fixes the issue.
Affected configurations
• apache answer (< 1.4.1)
Related
Weakness · CWE (1)
- CWE-326 Inadequate Encryption Strength weakness
References
- https://lists.apache.org/thread/sz2d0z39k01nbx3r9pj65t76o1hy9491 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/11/22/1 Mailing List