CVEvulnerability
CVE-2024-45772
8.0 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-09-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.1 MEDIUM — CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.
This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0.
The deprecated org.apache.lucene.replicator.http package is affected.
The org.apache.lucene.replicator.nrt package is not affected.
Users are recommended to upgrade to version 9.12.0, which fixes the issue.
The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.
Affected configurations
• apache lucene replicator (>= 4.4.0 < 9.12.0)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/3f3oph7bqnqspb9q5p0gm5mgc1b6thjo Mailing List, Mitigation, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/09/29/1 Third Party Advisory