CVEvulnerability

CVE-2024-46544

5.9 MEDIUM Published 2024-09-23 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-09-23
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
5.9 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-276

Description

Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service. This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected. Users are recommended to upgrade to version 1.2.50, which fixes the issue.

Affected configurations

• apache tomcat connectors (>= 1.2.9 < 1.2.50) • debian debian linux 11.0

Related

Weakness · CWE (1)

  • CWE-276 Incorrect Default Permissions weakness

References