CVEvulnerability
CVE-2024-47249
5.0 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-11-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.0 MEDIUM — CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-129
Description
Improper Validation of Array Index vulnerability in Apache NimBLE.
Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash.
This issue requires broken or bogus Bluetooth controller and thus severity is considered low.
This issue affects Apache NimBLE: through 1.7.0.
Users are recommended to upgrade to version 1.8.0, which fixes the issue.
Affected configurations
• apache nimble (< 1.8.0)
Related
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness
References
- https://github.com/apache/mynewt-nimble/commit/f39330866a85fa4de49246e9d21334bc8d14f0a1 Patch
- https://lists.apache.org/thread/7ckxw6481dp68ons627pjcb27c75n0mq Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/11/26/3 Mailing List, Vendor Advisory