CVEvulnerability

CVE-2024-5126

6.5 MEDIUM Published 2024-06-06 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-06-06
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 3.0 ([email protected])
7.6 HIGH — CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
Weaknesses
CWE-862

Description

An improper access control vulnerability exists in the lunary-ai/lunary repository, specifically within the versions.patch functionality for updating prompts. Affected versions include 1.2.2 up to but not including 1.2.25. The vulnerability allows unauthorized users to update prompt details due to insufficient access control checks. This issue was addressed and fixed in version 1.2.25.

Affected configurations

• lunary lunary (>= 1.2.2 < 1.2.25)

Related

Weakness · CWE (1)

  • CWE-862 Missing Authorization weakness

References