CVEvulnerability
CVE-2024-52301
8.7 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-11-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-88
Description
Laravel is a web application framework. When the register_argc_argv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. The vulnerability fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, and 11.31.0. The framework now ignores argv values for environment detection on non-cli SAPIs.
Affected configurations
• laravel framework (< 6.20.45)
• laravel framework (>= 7.0.0 < 7.30.7)
• laravel framework (>= 8.0.0 < 8.83.28)
• laravel framework (>= 9.0.0 < 9.52.17)
• laravel framework (>= 10.0.0 < 10.48.23)
• laravel framework (>= 11.0.0 < 11.31.0)
• debian debian linux 11.0
Related
Weakness · CWE (1)
- CWE-88 Improper Neutralization of Argument Delimiters in a Command weakness
References
- https://github.com/laravel/framework/security/advisories/GHSA-gv7v-rgg6-548h Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2024/12/msg00019.html Mailing List, Third Party Advisory