CVEvulnerability
CVE-2024-52518
5.4 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-11-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-287, CWE-863
Description
Nextcloud Server is a self hosted personal cloud system. After an attacker got access to the session of a user or administrator, the attacker would be able to create, change or delete external storages without having to confirm the password. It is recommended that the Nextcloud Server is upgraded to 28.0.12, 29.0.9 or 30.0.2.
Affected configurations
• nextcloud nextcloud server (>= 28.0.0 < 28.0.12)
• nextcloud nextcloud server (>= 29.0.0 < 29.0.9)
• nextcloud nextcloud server (>= 30.0.0 < 30.0.2)
Related
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vrhf-532w-99rg Vendor Advisory
- https://github.com/nextcloud/server/pull/48373 Issue Tracking
- https://github.com/nextcloud/server/pull/48788 Issue Tracking
- https://github.com/nextcloud/server/pull/48992 Issue Tracking
- https://hackerone.com/reports/2602973 Permissions Required