CVEvulnerability

CVE-2024-53949

7.6 HIGH Published 2024-12-09 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-12-09
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.6 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-863

Description

Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.  issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Affected configurations

• apache superset (>= 2.0.0 < 4.1.0)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References