CVEvulnerability

CVE-2024-54677

5.3 MEDIUM Published 2024-12-17 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-12-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-400

Description

Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.

Affected configurations

• apache tomcat (>= 9.0.0 < 9.0.98) • apache tomcat (>= 10.1.0 < 10.1.34) • apache tomcat (>= 11.0.0 < 11.0.2) • netapp bootstrap os

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References