CVEvulnerability
CVE-2024-54779
5.4 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-05-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds is vulnerable to Cross Site Scripting (XSS) in widgets/log.widget.php.
Affected configurations
• netgate pfsense ce (< 2.8.0)
• netgate pfsense plus (< 25.03)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://blog.brillantit.com/exploiting-pfsense-xss-command-injection-cloud-hijack/ Exploit, Third Party Advisory
- https://docs.netgate.com/downloads/pfSense-SA-25_01.webgui.asc Mailing List, Vendor Advisory
- https://www.netgate.com/blog/important-security-updates-for-pfsense-plus-24.11-and-ce-2.7.2 Release Notes