CVEvulnerability
CVE-2024-54780
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-05-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds are vulnerable to command injection in the OpenVPN widget due to improper sanitization of user-supplied input to the OpenVPN management interface. An authenticated attacker can exploit this vulnerability by injecting arbitrary OpenVPN management commands via the remipp parameter.
Affected configurations
• netgate pfsense ce (< 2.8.0)
• netgate pfsense plus (< 25.03)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://blog.brillantit.com/exploiting-pfsense-xss-command-injection-cloud-hijack/ Exploit, Third Party Advisory
- https://www.netgate.com/blog/important-security-updates-for-pfsense-plus-24.11-and-ce-2.7.2 Patch, Vendor Advisory