CVEvulnerability

CVE-2024-5566

6.5 MEDIUM Published 2024-07-16 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-07-16
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-269

Description

An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal Access Token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17.

Affected configurations

• github enterprise server (>= 3.9.0 < 3.9.17) • github enterprise server (>= 3.10.0 < 3.10.14) • github enterprise server (>= 3.11.0 < 3.11.12) • github enterprise server (>= 3.12.0 < 3.12.6) • github enterprise server 3.13.0

Related

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References