CVEvulnerability
CVE-2024-55879
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-12-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-862
Description
XWiki Platform is a generic wiki platform. Starting in version 2.3 and prior to versions 15.10.9, 16.3.0, any user with script rights can perform arbitrary remote code execution by adding instances of `XWiki.ConfigurableClass` to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This has been patched in XWiki 15.10.9 and 16.3.0. No known workarounds are available except upgrading.
Affected configurations
• xwiki xwiki (>= 2.3 < 15.10.9)
• xwiki xwiki (>= 16.0.0 < 16.3.0)
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://github.com/xwiki/xwiki-platform/commit/8493435ff9606905a2d913607d6c79862d0c168d Patch
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-r279-47wg-chpr Vendor Advisory
- https://jira.xwiki.org/browse/XWIKI-21207 Exploit, Vendor Advisory
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-wh34-m772-5398 Not Applicable