CVEvulnerability

CVE-2024-56145

9.3 CRITICAL Known exploited Published 2024-12-18 Modified 2026-06-17 Official page ↗

CISA Known Exploited Vulnerability

Craft CMS Code Injection Vulnerability — Craft CMS Craft CMS

Craft CMS contains a code injection vulnerability. Users with affected versions are vulnerable to remote code execution if their php.ini configuration has `register_argc_argv` enabled.

Added to KEV
2025-06-02
Remediation due
2025-06-23
Ransomware use
Unknown
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Notes
https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9 ; https://nvd.nist.gov/vuln/detail/CVE-2024-56145
Status
Analyzed
Published
2024-12-18
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
9.3 CRITICAL — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

Affected configurations

• craftcms craft cms (>= 3.0.0 < 3.9.14) • craftcms craft cms (>= 4.0.0 < 4.13.2) • craftcms craft cms (>= 5.0.0 < 5.5.2)

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References