CVEvulnerability

CVE-2024-5817

5.9 MEDIUM Published 2024-07-16 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-07-16
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
5.9 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Amber
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-863

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed read access to issue content via GitHub Projects. This was only exploitable in internal repositories and required the attacker to have access to the corresponding project board. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (>= 3.9.0 < 3.9.17) • github enterprise server (>= 3.10.0 < 3.10.14) • github enterprise server (>= 3.11.0 < 3.11.12) • github enterprise server (>= 3.12.0 < 3.12.6) • github enterprise server 3.13.0

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References