CVEvulnerability
CVE-2024-6000
7.1 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2024-06-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-285
Description
The FooEvents for WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary file uploads due to an improper capability setting on the 'display_ticket_themes_page' function in versions up to, and including, 1.19.20. This makes it possible for authenticated attackers with contributor-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible. This was partially patched in 1.19.20, and fully patched in 1.19.21.
Related
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://help.fooevents.com/docs/topics/changelogs/fooevents-for-woocommerce/ help.fooevents.com
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1080810b-ec9a-44fb-b4da-49b28646a441?source=cve www.wordfence.com
- https://help.fooevents.com/docs/topics/changelogs/fooevents-for-woocommerce/ help.fooevents.com
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1080810b-ec9a-44fb-b4da-49b28646a441?source=cve www.wordfence.com