CVEvulnerability

CVE-2024-8263

6.2 MEDIUM Published 2024-09-23 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-09-23
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
6.2 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:L/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
2.7 LOW — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-269

Description

An improper privilege management vulnerability allowed arbitrary workflows to be committed using an improperly scoped PAT through the use of nested tags. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (>= 3.10.0 < 3.10.17) • github enterprise server (>= 3.11.0 < 3.11.15) • github enterprise server (>= 3.12.0 < 3.12.9) • github enterprise server (>= 3.13.0 < 3.13.4) • github enterprise server 3.14.0

Related

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References