CVEvulnerability

CVE-2024-8810

8.7 HIGH Published 2024-11-07 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-11-07
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
8.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:P/AU:N/R:U/V:C/RE:L/U:Amber
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-269

Description

A GitHub App installed in organizations could upgrade some permissions from read to write access without approval from an organization administrator. An attacker would require an account with administrator access to install a malicious GitHub App. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.14.1, 3.13.4, 3.12.9, 3.11.15, and 3.10.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (>= 3.10.0 < 3.10.17) • github enterprise server (>= 3.11.0 < 3.11.15) • github enterprise server (>= 3.12.0 < 3.12.9) • github enterprise server (>= 3.13.0 < 3.13.4) • github enterprise server 3.14.0

Related

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References