CVEvulnerability

CVE-2025-0914

3.8 LOW Published 2025-02-27 Modified 2026-06-17 Official page ↗
Status
Deferred
Published
2025-02-27
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
3.8 LOW — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-281

Description

An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.

Related

Weakness · CWE (1)

  • CWE-281 Improper Preservation of Permissions weakness

References