CVEvulnerability
CVE-2025-10861
7.5 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2025-10-24
- Last modified
- 2026-10-08
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-918
Description
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.1.4. This is due to insufficient validation on the URLs supplied via the URL parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services, as well as conduct network reconnaissance. The vulnerability was partially patched in version 2.1.4.
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.2/includes/Routes/FetchDemo.php#L15 plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.2/includes/Routes/FetchDemo.php#L35 plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3369146/ plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3379308/ plugins.trac.wordpress.org
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5f4767b5-5dd6-4a2a-b44a-5297432286b1?source=cve www.wordfence.com