CVEvulnerability
CVE-2025-1215
2.4 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2025-02-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.4 LOW — CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 2.8 LOW — CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 1.7 LOW — AV:L/AC:L/Au:S/C:N/I:N/A:P
- Weaknesses
- CWE-119
Description
A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.
Affected configurations
• vim vim (< 9.1.1097)
• netapp bootstrap os
Related
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://github.com/vim/vim/commit/c5654b84480822817bb7b69ebc97c174c91185e9 Patch
- https://github.com/vim/vim/issues/16606 Exploit, Issue Tracking
- https://github.com/vim/vim/releases/tag/v9.1.1097 Release Notes
- https://vuldb.com/?ctiid.295174 Permissions Required, VDB Entry
- https://vuldb.com/?id.295174 Third Party Advisory, VDB Entry
- https://vuldb.com/?submit.497546 Third Party Advisory, VDB Entry
- https://security.netapp.com/advisory/ntap-20250321-0005/ Third Party Advisory
- https://github.com/vim/vim/issues/16606 Exploit, Issue Tracking
- https://vuldb.com/?submit.497546 Third Party Advisory, VDB Entry