CVEvulnerability
CVE-2025-13428
8.6 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-09
- Last modified
- 2026-10-07
- Assigner
- f45cbf4e-4146-4068-b7e1-655ffc2c548c
- CVSS 4.0 (f45cbf4e-4146-4068-b7e1-655ffc2c548c)
- 8.6 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Clear
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, leading to potential server compromise.
No customer action is required.
All customers have been automatically upgraded to the fixed version: 6.3.64 or higher.
Affected configurations
• google security operations soar (< 6.3.64)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://cloud.google.com/support/bulletins#gcp-2025-075 Vendor Advisory