CVEvulnerability
CVE-2025-15444
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-01-06
- Last modified
- 2026-10-07
- Assigner
- 9b29abf9-4ab0-4765-b253-1875cd9b441e
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-347
Description
Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium
libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277 https://www.cve.org/CVERecord?id=CVE-2025-69277 .
The libsodium vulnerability states:
In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.
0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.
Affected configurations
• iamb crypt\ \ (< 0.000042)
Related
Weakness · CWE (1)
- CWE-347 Improper Verification of Cryptographic Signature weakness
References
- https://00f.net/2025/12/30/libsodium-vulnerability/ Third Party Advisory
- https://github.com/jedisct1/libsodium/commit/ad3004ec8731730e93fcfbbc824e67eadc1c1bae Patch
- https://metacpan.org/dist/Crypt-Sodium-XS/changes Product, Release Notes