CVEvulnerability
CVE-2025-1756
7.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-02-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-426
Description
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0
Affected configurations
• mongodb mongosh (< 2.3.0)
• redhat codeready linux builder eus 9.4
• redhat codeready linux builder for arm64 eus 9.4 aarch64
• redhat codeready linux builder for ibm z systems eus 9.4 s390x
• redhat codeready linux builder for power little endian eus 9.4 ppc64le
• redhat enterprise linux update services for sap solutions 9.4
• redhat enterprise linux eus 9.4
• redhat enterprise linux for arm 64 9.4 aarch64
• redhat enterprise linux for arm 64 eus 9.4 aarch64
• redhat enterprise linux for ibm z systems 9.4 s390x
• redhat enterprise linux for ibm z systems eus 9.4 s390x
• redhat enterprise linux for power little endian eus 9.4 ppc64le
• redhat enterprise linux server aus 9.4
Related
Weakness · CWE (1)
- CWE-426 Untrusted Search Path weakness
References
- https://jira.mongodb.org/browse/MONGOSH-2028 Issue Tracking, Vendor Advisory
- https://access.redhat.com/errata/RHSA-2025:1756 Third Party Advisory