CVEvulnerability
CVE-2025-21617
6.3 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2025-01-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 6.3 MEDIUM — CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-338
Description
Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.
Related
Weakness · CWE (1)
- CWE-338 Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) weakness
References
- https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192 github.com
- https://github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53 github.com
- https://github.com/guzzle/oauth-subscriber/releases/tag/0.8.1 github.com
- https://github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88 github.com