CVEvulnerability
CVE-2025-21621
6.1 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-25
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.25.0, a reflected cross-site scripting (XSS) vulnerability exists in the WMS GetFeatureInfo HTML output format that enables a remote attacker to execute arbitrary JavaScript code in a victim's browser through specially crafted SLD_BODY parameters. This issue has been patched in version 2.25.0.
Affected configurations
• geoserver geoserver (< 2.25.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/geoserver/geoserver/commit/dc9ff1c726dd73c884437a123b4ad72b19383c7d Patch
- https://github.com/geoserver/geoserver/pull/7406 Issue Tracking
- https://github.com/geoserver/geoserver/security/advisories/GHSA-w66h-j855-qr72 Vendor Advisory
- https://osgeo-org.atlassian.net/browse/GEOS-11297 Issue Tracking