CVEvulnerability

CVE-2025-23015

8.8 HIGH Published 2025-02-04 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-02-04
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-267

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Affected configurations

• apache cassandra (>= 3.0.0 < 3.0.31) • apache cassandra (>= 3.1 < 3.11.18) • apache cassandra (>= 4.0.0 < 4.0.16) • apache cassandra (>= 4.1.0 < 4.1.8) • apache cassandra (>= 5.0.0 < 5.0.3)

Related

Weakness · CWE (1)

  • CWE-267 Privilege Defined With Unsafe Actions weakness

References