CVEvulnerability
CVE-2025-24013
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-01-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-436
Description
CodeIgniter is a PHP full-stack web framework. Prior to 4.5.8, CodeIgniter lacked proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application. This vulnerability is fixed in 4.5.8.
Affected configurations
• codeigniter codeigniter (< 4.5.8)
Related
Weakness · CWE (1)
- CWE-436 Interpretation Conflict weakness
References
- https://datatracker.ietf.org/doc/html/rfc7230#section-3.2 Technical Description
- https://github.com/advisories/GHSA-wxmh-65f7-jcvw Not Applicable
- https://github.com/codeigniter4/CodeIgniter4/commit/5f8aa24280fb09947897d6b322bf1f0e038b13b6 Patch
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-x5mq-jjr3-vmx6 Vendor Advisory