CVEvulnerability

CVE-2025-24813

9.8 CRITICAL Known exploited Published 2025-03-10 Modified 2026-06-17 Official page ↗

CISA Known Exploited Vulnerability

Apache Tomcat Path Equivalence Vulnerability — Apache Tomcat

Apache Tomcat contains a path equivalence vulnerability that allows a remote attacker to execute code, disclose information, or inject malicious content via a partial PUT request. This vulnerability can be chained with CVE‑2026‑34486.

Added to KEV
2025-04-01
Remediation due
2025-04-22
Ransomware use
Unknown
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Notes
This vulnerability affects a common open-source component, third-party library, or a protocol used by different products. Please check with specific vendors for information on patching status. For more information, please see: https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq ; https://nvd.nist.gov/vuln/detail/CVE-2025-24813
Status
Analyzed
Published
2025-03-10
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
10.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-44, CWE-502, CWE-706

Description

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

Affected configurations

• apache tomcat (< 9.0.99) • apache tomcat (>= 10.1.1 < 10.1.35) • apache tomcat (>= 11.0.1 < 11.0.3) • apache tomcat 10.1.0 • apache tomcat 11.0.0 • debian debian linux 11.0 • netapp bootstrap os

Related

Weakness · CWE (3)

  • CWE-44 Path Equivalence: 'file.name' (Internal Dot) weakness
  • CWE-502 Deserialization of Untrusted Data weakness
  • CWE-706 Use of Incorrectly-Resolved Name or Reference weakness

Referenced by CWE · observed example (1)

  • CWE-44 Path Equivalence: 'file.name' (Internal Dot) weakness

References