CVEvulnerability
CVE-2025-24854
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2025-07-31
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
A carefully crafted request using the Image plugin could trigger an XSS
vulnerability on Apache JSPWiki, which could allow the attacker to
execute javascript in the victim's browser and get some sensitive
information about the victim.
Apache JSPWiki users should upgrade to 2.12.3 or later.
Affected configurations
• apache jspwiki (< 2.12.3)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2025-24854 Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/30/3 www.openwall.com