CVEvulnerability
CVE-2025-24860
5.4 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-02-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
Description
Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer.
Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions.
This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer.
Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Affected configurations
• apache cassandra (>= 4.0.0 < 4.0.16)
• apache cassandra (>= 4.1.0 < 4.1.8)
• apache cassandra (>= 5.0.0 < 5.0.3)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://lists.apache.org/thread/yjo5on4tf7s1r9qklc4byrz30b8vkm2d Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/02/03/3 Mailing List, Vendor Advisory
- https://security.netapp.com/advisory/ntap-20250214-0005/ Third Party Advisory