CVEvulnerability
CVE-2025-2598
5.7 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2025-03-21
- Last modified
- 2026-06-17
- Assigner
- ff89ba41-3aa1-4d27-914a-91399e9639e5
- CVSS 4.0 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
- 5.7 MEDIUM — CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-497
Description
When the AWS Cloud Development Kit (AWS CDK) Command Line Interface (AWS CDK CLI) is used with a credential plugin which returns an expiration property with the retrieved AWS credentials, the credentials are printed to the console output. To mitigate this issue, users should upgrade to version 2.178.2 or later and ensure any forked or derivative code is patched to incorporate the new fixes.
Affected configurations
• amazon aws cloud development kit (>= 2.172.0 < 2.178.2)
Related
Weakness · CWE (1)
- CWE-497 Exposure of Sensitive System Information to an Unauthorized Control Sphere weakness