CVEvulnerability
CVE-2025-26269
5.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-04-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.3 LOW — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-191
Description
DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated users to cause a denial of service (daemon crash) via a Lua library command that references a large negative integer.
Affected configurations
• dragonflydb dragonfly (< 1.29.0)
Related
Weakness · CWE (1)
- CWE-191 Integer Underflow (Wrap or Wraparound) weakness
References
- https://gist.github.com/ankki-zsyang/d8215cf6e868d07546eaa5346a884ebd Exploit, Third Party Advisory
- https://github.com/dragonflydb/dragonfly/commit/4612aec9a78e3f604e6fb19bee51acde89723308 Patch
- https://github.com/dragonflydb/dragonfly/issues/4468 Exploit, Issue Tracking, Patch
- https://github.com/dragonflydb/dragonfly/issues/4468 Exploit, Issue Tracking, Patch