CVEvulnerability
CVE-2025-26413
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-04-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
Improper Input Validation vulnerability in Apache Kvrocks.
The SETRANGE command didn't check if the `offset` input is a positive integer and use it as an index
of a string. So it will cause the server to crash due to its index is out of range.
This issue affects Apache Kvrocks: through 2.11.1.
Users are recommended to upgrade to version 2.12.0, which fixes the issue.
Affected configurations
• apache kvrocks (< 2.12.0)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://lists.apache.org/thread/388743qrr8yq8qm0go8tls6rf1kog8dw Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/04/22/1 Mailing List, Third Party Advisory