CVEvulnerability
CVE-2025-26864
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-05-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200, CWE-532
Description
Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in the OpenIdAuthorizer of Apache IoTDB.
This issue affects Apache IoTDB: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2.
Users are recommended to upgrade to version 1.3.4 and 2.0.2, which fix the issue.
Affected configurations
• apache iotdb (>= 0.10.0 < 1.3.4)
• apache iotdb 2.0.1
Related
References
- https://lists.apache.org/thread/2kcjnlypppk8qjh17dpz0jvkcpn6l162 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/05/14/4 Mailing List